Philips Hue Feedback

Share any commands you know or look here to find commands for your devices.
Post Reply
starwarsmike
Posts: 146
Joined: Mon May 13, 2013 12:48 pm

Philips Hue Feedback

Post by starwarsmike » Sat Nov 04, 2017 8:53 am

Hi

Has anyone successfully managed to get Philips hue feedback working? for some reason I just can get mine working?

I can send a command no problem to all my lights, using the Hue debug I get this response each time I turn light on or off.

[
{
"success": {
"/lights/1/state/on": false
}
}
]

So, In feedback I setup "feedback matches specific data" = "/lights/2/state/on": false. Setup up a standard label (with text saying light off)l and attached label to a button in text section dynamic label. I've also tried "feedback matches a pattern"

In feedback response terminator i have tried \x0D & \x0A and both, nothing works

Any help appreciated

cv27
Posts: 230
Joined: Sat Nov 24, 2012 10:15 pm
Location: Montréal, QC, Canada

Re: Philips Hue Feedback

Post by cv27 » Sat Nov 04, 2017 9:44 pm

Just a hunch but have you tried to debug with Hercules or whatever to visualize what the Hex terminator actually is in the Hue responses?

Just a wild guess, but that double quote, although legal AFAIK, might cause issue. You may want to replace it with a dot.

AKWillows
Posts: 53
Joined: Mon Aug 25, 2014 5:46 pm

Re: Philips Hue Feedback

Post by AKWillows » Mon Nov 26, 2018 10:24 pm

Did anyone get this working?

mpg732
Posts: 2
Joined: Fri Feb 27, 2015 2:43 am

Re: Philips Hue Feedback

Post by mpg732 » Sun Feb 10, 2019 4:51 am

response terminator I have }


Command used to get all light info

GET /api/Y1Vpd5qwJVnjsRIdxFThJR0jxcrnZaEvrQVe0NYM/lights HTTP/1.1\x0D\x0AHOST:192.168.1.127:80\x0D\x0A\x0D\x0A

If I remember correctly I believe every time you send a command to change light you will get a response.

AKWillows
Posts: 53
Joined: Mon Aug 25, 2014 5:46 pm

Re: Philips Hue Feedback

Post by AKWillows » Sun Feb 10, 2019 11:16 am

Thanks. Will give it another go!

AKWillows
Posts: 53
Joined: Mon Aug 25, 2014 5:46 pm

Re: Philips Hue Feedback

Post by AKWillows » Wed May 15, 2019 7:13 pm

Hi - still struggling with the feedback.. it's just come back to the front of my mind so thought I would try again!!

I absolutely get the command to send... and I can see the response format using the Hue API debug tool. I am successfully using the commands to control the lights, but what I can't do is to get the 2-way feedback configured properly in Demopad.

What I am trying to achieve is... if the feedback says light 1 is on, then set a flag so that I can highlight the "on" button. Likewise for "off". And then repeat for each of my lights!

So, can anyone help with the format they have used in the Demopad 2-way feedback section in order to capture the correct status? I think the response Hue send is still in the same format as @starwarsmike originally posted... so what would the capture phrase me in the two-way feedback?

Post Reply