Strange happening

Forum to ask for any help
Post Reply
Posts: 74
Joined: Wed Mar 07, 2018 1:19 am

Strange happening

Post by anderdea » Sat Mar 31, 2018 2:53 pm

I was using my newly developed DemoPad iPad app last night and on the whole everything was working OK. I went to use the cursor controls for my Dish satellite (IR) receiver an didn’t get any response. I switched over to my iRule app and all worked as intended. When I went to shut everything down using an established macro, my Denon receiver wouldn’t turn off (IP). Again I went to iRule and it shut down fine. I then closed DemoPad and restarted it and all was working again. Any ideas. I’m running IOS version: 11.2.6.

I have been using the DemoPad app for the better part of 3 weeks during development with no issues and the IOS was updated prior to the DemoPad development.

Posts: 231
Joined: Sat Nov 24, 2012 10:15 pm
Location: Montréal, QC, Canada

Re: Strange happening

Post by cv27 » Sat Mar 31, 2018 6:29 pm

When I ran DemoPad solo (I now use a Centro-M), I used to get into these situations here and there and, as you, would kill and restart the app so things would go again.

There is also 'disconnect from/connect to device' commands available you could try that close/reopen the TCP conversation, but those never worked for me.

Post Reply