Sony Projector IP command issue

Forum to ask for any help
Post Reply
anderdea
Posts: 52
Joined: Wed Mar 07, 2018 1:19 am

Sony Projector IP command issue

Post by anderdea » Sat Mar 24, 2018 7:39 pm

I’m trying to get my Sony 4K Projector to accept commands as it does OK in iRule.
I’ve set up a new device IP 192.168.xx.xx and using port 53483 (this is what iRule is accepting). The port is open as sending it through pre-defined commands doesn’t return any errors. Maintain active connection checked.

The ON command (copied from my iRule database page) is:
\x02\x0A\x53\x4F\x4E\x59\X00\X17\X2E\x02\x00\x\00

Admittedly I’m out of my element here. Is there a conversion or another way I should be entering this command into designer?

anderdea
Posts: 52
Joined: Wed Mar 07, 2018 1:19 am

Re: Sony Projector IP command issue

Post by anderdea » Sat Mar 24, 2018 9:33 pm

I found the Sony model VPL IR codes in The Global Cache Database. I’m going to go with IR, much easier. Tested IR Power ON and OFF and they work.

Well I guess I need to mix TCP/IP codes with some IR codes as I did in iRule to get all the commands to buttons working. Some of the iR commands aren’t working.

I’m right back where I started trying to decifer the IP address codes!

cv27
Posts: 228
Joined: Sat Nov 24, 2012 10:15 pm
Location: Montréal, QC, Canada

Re: Sony Projector IP command issue

Post by cv27 » Sun Mar 25, 2018 5:12 pm

Try using some network tool such as Hercules to first test out your commands. Much faster to setup and test and your get the integral response from the device. The response will often give clues as to what's wrong.

Also make sure you have the right command suffix. In cases where the device does not accept a command suffix, beware also when copying strings into the DemoPad command window: often, the copy will include a CrLf that's not apparent but the giveaway is that the cursor ends up on the next line (I've been bit by that one a few times).

IR is fine if it's all you have, but IP is much faster with 2-way feedback with many devices.

User avatar
DemoPad
Site Admin
Posts: 711
Joined: Thu Jun 14, 2012 10:46 am
Contact:

Re: Sony Projector IP command issue

Post by DemoPad » Sun Mar 25, 2018 5:43 pm

anderdea wrote:
Sat Mar 24, 2018 7:39 pm

The ON command (copied from my iRule database page) is:
\x02\x0A\x53\x4F\x4E\x59\X00\X17\X2E\x02\x00\x\00
That doesn't look correct. All hex byes should be entered in \xHH where H = 0-9 or A-F (capital).

So \X00 and \x\00 looks odd.

Agree that testing with Hercules (which uses $ format for hex bytes, eg $02$0A... is the way to go.

anderdea
Posts: 52
Joined: Wed Mar 07, 2018 1:19 am

Re: Sony Projector IP command issue

Post by anderdea » Sun Mar 25, 2018 9:49 pm

I’m not familiar with Hercules?

1. Original with typo
\x02\x0A\x53\x4F\x4E\x59\X00\X17\X2E\x02\x00\x\00

2. Sorry I had a typo it looks like this but still has the \X00
\x02\x0A\x53\x4F\x4E\x59\X00\X17\X2E\x02\x00\x00

3. THANKS FOR THE CODE CATCH. Interestingly enough, on a hunch I changed the upper case ‘X’ to a lower case ‘x’ in the command string and the command worked. I have the command code pdf protocol manual from Sony for the ES line of projectors but haven’t been able to decifer it’s structure.

cv27
Posts: 228
Joined: Sat Nov 24, 2012 10:15 pm
Location: Montréal, QC, Canada

Re: Sony Projector IP command issue

Post by cv27 » Mon Mar 26, 2018 4:32 pm

anderdea wrote:
Sun Mar 25, 2018 9:49 pm
I’m not familiar with Hercules?
Info on Hercules https://www.hw-group.com/products/hercu ... ex_en.html. But there are other utilities (Packet Sender, IPtools ...).

jj_1
Posts: 3
Joined: Mon Sep 22, 2014 4:57 pm

Re: Sony Projector IP command issue

Post by jj_1 » Fri May 25, 2018 1:07 pm

Hello anderdea
Can you post Pdf for the Sony?
I have also a Sony 4K Projector and figured out the most codes but i still miss some.

anderdea
Posts: 52
Joined: Wed Mar 07, 2018 1:19 am

Re: Sony Projector IP command issue

Post by anderdea » Sat Jun 09, 2018 4:35 pm

Sorry for not getting back to you. Haven’t checked forum in a while.
I’m not sure how to attach a pdf to a post? I’ll send the file if someone can give me some direction.

cv27
Posts: 228
Joined: Sat Nov 24, 2012 10:15 pm
Location: Montréal, QC, Canada

Re: Sony Projector IP command issue

Post by cv27 » Sat Jun 09, 2018 8:34 pm

UPDATE: Sorry, didn't focus on PDF. Just change the extension for ZIP ro TXT and ask the receiver to change it back to PDF.
snip_20180609153429.png
You do not have the required permissions to view the files attached to this post.

Post Reply