Lightwaverf and Veralite

General Discussion on DemoPad or related products
Post Reply
ChrisB75
Posts: 52
Joined: Sun Feb 17, 2013 1:11 pm

Lightwaverf and Veralite

Post by ChrisB75 » Wed Nov 27, 2013 11:51 am

In case anyone is interested, here is a way to get feedback from lighgtwaverf dimmers using a Veralite with 433mHx transceiver. I set this up, with the usual fantastic help from Demopad, as I wanted to change from my existing lightwaverf to z-wave using a Veralite for real-time device status but can't afford to change all my lightwaverf gear at once. This way, I can get z-wave switches one at a time and still use my lighwaverf kit with feedback - please note though that the feedback only works for the lightwaverf switches and dimmers if they are controlled through the Veralite - if you change the devices using its switch or another app, the feedback will not relate to the device's actual state. Plus you need a 433mHz transceiver but this is still a cheaper option than buying lots of z-wave switches/dimmers at once.
To use this, you have to first set-up the 433mHz transceiver with Veralite and there is info about this on the internet.
A command is sent (either through a page load action or using a button - I use a page load action on my lighting page sending the command every 5 seconds) to retrieve info about the device states using;

http://VERALITEIPADDRESS:3480/data_requ ... format=xml, entering your LAN IP address of the VERALITE

Then set-up 2-way feedback for each device using "feedback matches a pattern" and sending the captured data as a number to the number you use for the device dimmer, for example, that is also linked to a gauge for that dimmer;

"Main Dimmer".*"(.*)"
"Lamp Dimmer".*"(.*)"
and so on.

That's it, your gauges should now display the state of your lighwaverf dimmers :D I haven't tried it for switches yet but presumably the same will work except you will only have 2 states; "0" for off and "1" for on.
It seems to work with "Maintain active connection" on or off. I hope that makes sense, enjoy :D
Feel free to post or PM me any questions.
Cheers

ChrisB75
Posts: 52
Joined: Sun Feb 17, 2013 1:11 pm

Re: Lightwaverf and Veralite

Post by ChrisB75 » Sat Nov 30, 2013 9:19 pm

Some additional info after using for a while and adding feedback for device status, i.e. on or off.

Create a device for the Veralite, enter the ip and use 3480 as the port.

For a dimmer (change DeviceNum=?? and newLoadLevelTarget=?? for each device and dimming level)

GET /data_request?id=action&DeviceNum=9&serviceId=urn:upnp-org:serviceId:Dimming1&action=SetLoadLevelTarget&newLoadlevelTarget=10 HTTP/1.1\x0D\x0AConnection: close\x0D\x0A

For a plug (change DeviceNum=?? and newTarget=1 for oon and 0 for off for each device)

GET /data_request?id=action&output_format=xml&DeviceNum=23&serviceId=urn:upnp-org:serviceId:SwitchPower1&action=SetTarget&newTargetValue=1 HTTP/1.1\x0D\x0AConnection: close\x0D\x0A

To get status
GET /data_request?id=sdata&output_format=xml HTTP/1.1\x0D\x0AConnection: close\x0D\x0A

To set a scene (change SceneNum=?? for each scene - these have to be set up on Veralite)

GET /data_request?id=lu_action&serviceId=urn:micasaverde-com:serviceId:HomeAutomationGateway1&action=RunScene&SceneNum=2 HTTP/1.1\x0D\x0AConnection: close\x0D\x0A

Feedback matches a pattern to the relevant number for each dimmer level and this can be linked to a gauge if you use one for dimming. These are the feedbacks I use but you will need to change the name depending on your set-up. If you put YOURVERAIP:3480/data_request?id=sdata&output_format=xml in a browser address, it will return the file that the feedback is based on and you will see your device names here. When retrieving status, I found you had to add an action to the feedback for it to work, I have no idea why!? I have a number for each status, e.g. MainDimmerStatus min value 0 max value 1 default value 0 and in the feedback action "set a number" MainDimmerStatus={+]0

Set device response terminator to </root>

.*"Main Dimmer".*level="(.*)".
.*"Pyramid Dimmer".*level="(.*)".
.*"Wood Dimmer".*level="(.*)".
.*"OfficeMain".*level="(.*)".
.*"OfficeOutside".*level="(.*)".
<dev.*"GarageLights".*status="(.*)".
<dev.*"iTachPlug".*status="(.*)".
"KitchenCabinet".*status="(.*)".
.*Main Dimmer".*status="(.*)"\s
Pyramid Dimmer".*status="(.*)"\s
Wood Dimmer".*status="(.*)"\s
OfficeMain".*status="(.*)".
OfficeOutside".*status="(.*)".

Hope that's of use :D

User avatar
Cheesegeezer
Posts: 27
Joined: Wed Mar 02, 2016 10:15 pm
Location: On an oil rig somewhere

Re: Lightwaverf and Veralite

Post by Cheesegeezer » Tue Feb 07, 2017 1:15 pm

Hi Chris,

I'm trying to muddle my way thru this 2 way feedback. I'm using the Vera Edge, but all the protocols are the same.

I can't for the life of me get it to work. I'm just curious if there are any typo's in your feed back list you have kindly shared.

Could you please post some screen shots for dimming and for status please. And also a screenshot for your feedback actions window.

Any help would be greatly appreciated.

Here is what I have currently, however I've tried many different combinations.

https://www.dropbox.com/s/y5v8phyfgncmu ... 5.png?dl=0

User avatar
Cheesegeezer
Posts: 27
Joined: Wed Mar 02, 2016 10:15 pm
Location: On an oil rig somewhere

Re: Lightwaverf and Veralite

Post by Cheesegeezer » Tue Feb 07, 2017 6:22 pm

Maybe you guys at @Demopad may be so kind as to help me out with this.

https://www.dropbox.com/s/qztwjzmxphkm6 ... 5.png?dl=0

I've attached a screenie of the regex debugger I'm using.

http://www.regextester.com/

So I'm firing a status request when the page loads and is resent every 5 seconds.

Lets say it's a binary for if a light is on, so should return a O or 1. This is then sent to a Demopad Number set. With min at 0, max at 1 and default at 0. Hex is not ticked and there are no custom actions set.

Here is a screen shot of the 2 way feed back window including a Pattern

https://www.dropbox.com/s/p8zzojibhzop4 ... 5.png?dl=0

Here is screenshot of the actions window from the feedback window. I have it selected to just display a label using the numbers data returned from the regex query. So in theory it should display a 0 or 1 on the label.

https://www.dropbox.com/s/lgiwb49wmu2k1 ... 2.png?dl=0

This is where it all falls down, I get nothing. Using Fiddler allows me to view the request and the response which is all fine. I can't for the life of me get this working. And all the people that have other than Chris haven't shared their solutions unfortunately.

Please help

User avatar
DemoPad
Site Admin
Posts: 714
Joined: Thu Jun 14, 2012 10:46 am
Contact:

Re: Lightwaverf and Veralite

Post by DemoPad » Wed Feb 08, 2017 4:01 pm

Quotation marks need to be escaped with \

Post Reply