Search found 736 matches

by DemoPad
Tue Oct 19, 2021 11:13 am
Forum: Help Forum
Topic: Problem with Bluesound IP control
Replies: 2
Views: 98

Re: Problem with Bluesound IP control

Presume you mean \x0D\x0A as the suffix, not \x0D\X0A Try changing the IP address of the device to match your PC, and use Hercules in TCP Server mode to see what data comes in, and compare with what you send yourself from Hercules. Usually you need an extra \x0D\x0A at the end of the command. Does t...
by DemoPad
Mon Apr 12, 2021 1:12 pm
Forum: Help Forum
Topic: Creating multiple pages for an acitivity
Replies: 2
Views: 552

Re: Creating multiple pages for an acitivity

Subpages can scroll via a swipe, which is the usual approach for this kind of thing - please see http://designer.docs.demopad.com/pages/subpages/
by DemoPad
Mon Jan 11, 2021 5:46 pm
Forum: Help Forum
Topic: Format for HTTP REST GET commands
Replies: 3
Views: 4236

Re: Format for HTTP REST GET commands

When forming a url, you need to use $20 for spaces, which is the problem, as your retrieved feedback will contain actual space characters which are invalid url characters. In the next version of the CentroControl app, the 'send data to website' action type (which you can use for GET requests requiri...
by DemoPad
Wed Dec 23, 2020 10:43 am
Forum: Help Forum
Topic: Toggle button and Hue
Replies: 10
Views: 1897

Re: Toggle button and Hue

The Bad Request response above is likely because you are using \x instead of $ for the hex characters - Hercules requires that you use $0D instead of \x0D - suggest using text rather than your online hex converter, which will be taking \x0D\x0A and treating it as 8 characters, rather than the 2 it s...
by DemoPad
Tue Dec 22, 2020 10:53 am
Forum: Help Forum
Topic: Toggle button and Hue
Replies: 10
Views: 1897

Re: Toggle button and Hue

Ok - next thing to try is Hercules in TCP Client mode to see if you get the same behaviour. Note Hercules uses $ instead of \x so use $0D$0A instead of \x0D\x0A A few things I note in your commands though, after the Content-Length, you have \x0A\x0A - I would expect this to be \x0D\x0A. Plus the Con...
by DemoPad
Mon Dec 21, 2020 10:47 am
Forum: Help Forum
Topic: Toggle button and Hue
Replies: 10
Views: 1897

Re: Toggle button and Hue

Method 3 is the easiest approach, and you look to have it set up correctly. You can test using Hercules in TCP server mode, port 80 listen, and alter the IP address of the device in Designer to match your PC. That way you get to see the commands coming from the app in order to confirm they are corre...
by DemoPad
Fri Dec 18, 2020 5:01 pm
Forum: Help Forum
Topic: Re-arrange sub pages
Replies: 2
Views: 824

Re: Re-arrange sub pages

Not as such, but you can group pages and subpage into your own folders, which helps with organisation.
by DemoPad
Tue Nov 03, 2020 11:43 am
Forum: Help Forum
Topic: boxes offset after upload
Replies: 4
Views: 1425

Re: boxes offset after upload

This appears to be the case when the sizes of objects are different between portrait and landscape, and the portrait view takes the landscape sizing by mistake. An update will be available shortly to resolve this, it only affects the Android app, and only when the same mirrored object has a differen...
by DemoPad
Mon Oct 26, 2020 6:07 pm
Forum: Help Forum
Topic: boxes offset after upload
Replies: 4
Views: 1425

Re: boxes offset after upload

Is this on iOS or Android? If you send the .pad file in to support@demopad.com we will take a look.
by DemoPad
Fri Oct 23, 2020 10:10 am
Forum: General Discussion
Topic: Siemens Logo
Replies: 5
Views: 1477

Re: Siemens Logo

For the feedback to work, you need to specify a response terminator - a character or characters that the data ends with. You could try to match simply (true) and a separate (false) condition, but it doesn't look like the data ends with a known character, which makes feedback parsing difficult.
by DemoPad
Mon Oct 19, 2020 2:35 pm
Forum: Help Forum
Topic: Stop button spamming
Replies: 1
Views: 739

Re: Stop button spamming

Sure - just use a flag. Make the actions dependent on the flag being OFF. Then after the actions have happened, immediately set the flag ON, and then set it OFF after say 10 seconds. During those 10 seconds, further attempts to execute the commands will fail because the flag will be ON. Once it goes...
by DemoPad
Sun Oct 18, 2020 7:02 pm
Forum: General Discussion
Topic: Siemens Logo
Replies: 5
Views: 1477

Re: Siemens Logo

Yes, so that specifically says invalid host - you need to add the host parameter for HTTP 1.1 requests, eg

GET /rest/devices/1/methods/1 HTTP/1.1\x0D\x0AHost:logocontrol:8088\x0D\x0A
by DemoPad
Sat Oct 17, 2020 4:48 pm
Forum: General Discussion
Topic: Siemens Logo
Replies: 5
Views: 1477

Re: Siemens Logo

Suggest trying the command in Hercules to see any feedback which might give you a clue why it is not working. Note HTTP 1.1 GET requests require a host parameter, which might be one reason.
by DemoPad
Mon Sep 28, 2020 11:36 am
Forum: Help Forum
Topic: HTTP Command help
Replies: 3
Views: 1432

Re: HTTP Command help

All DemoPad does is transmit the command data you enter to a tcp/udp socket, it does not manipulate the data you enter in any way. Try comparing with Hercules running in TCP Server mode to confirm, and compare against postman.
by DemoPad
Fri Sep 25, 2020 9:13 am
Forum: Help Forum
Topic: HTTP Command help
Replies: 3
Views: 1432

Re: HTTP Command help

What is it that goes wrong? Do you get 'command sent' in Designer when you attempt it? Try running Hercules TCP server to see the actual data that comes in vs postman.